re = /PT\d+ @ [\d.]+/
str = 'abced @ 1.20689\\nLS @ 1.22000\\nPT1 @ 1.1900\\nPT2 @ 1.1800
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end