// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"PT\d+ @ [\d.]+").unwrap();
let string = "abced @ 1.20689\\nLS @ 1.22000\\nPT1 @ 1.1900\\nPT2 @ 1.1800
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}