using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<block>.Name[\s|\t]+data3[\s|\t]+.*?<\/block>";
string input = @"<block>
Name data1
Spec 36
</block>
<block>
Name data2
Spec 22
</block>
<block>
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}