const regex = /<block>.Name[\s|\t]+data3[\s|\t]+.*?<\/block>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<block>.Name[\\s|\\t]+data3[\\s|\\t]+.*?<\\\/block>', 'gms')
const str = `<block>
Name data1
Spec 36
</block>
<block>
Name data2
Spec 22
</block>
<block>
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}