package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<block>.Name[\s|\t]+data3[\s|\t]+.*?<\/block>`)
var str = `<block>
Name data1
Spec 36
</block>
<block>
Name data2
Spec 22
</block>
<block>
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}