import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?=.*[!\\{\\}\\[\\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\\{\\}\\[\\]@#$%^&*()+_<>~-].{7,14}$";
final String string = "TestHey@123!\n"
+ "@TestHey123!\n"
+ "aA1!1111\n"
+ "withoutupper1!\n"
+ "NOLOWERLETTER1!\n"
+ "NoDigits!\n"
+ "0SpecSymbols\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}