import re
regex = re.compile(r"^(?=.*[A-Z])(?=.*[!\{\}\[\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\{\}\[\]@#$%^&*()+_<>~-].{7,14}$", flags=re.MULTILINE)
test_str = ("TestHey@123!\n"
"@TestHey123!\n"
"aA1!1111\n"
"withoutupper1!\n"
"NOLOWERLETTER1!\n"
"NoDigits!\n"
"0SpecSymbols\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")