$re = '/^(?=.*[A-Z])(?=.*[!\{\}\[\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\{\}\[\]@#$%^&*()+_<>~-].{7,14}$/m';
$str = 'TestHey@123!
@TestHey123!
aA1!1111
withoutupper1!
NOLOWERLETTER1!
NoDigits!
0SpecSymbols
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);