#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z])(?=.*[!\{\}\[\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\{\}\[\]@#$%^&*()+_<>~-].{7,14}$"
Local $sString = "TestHey@123!" & @CRLF & _
"@TestHey123!" & @CRLF & _
"aA1!1111" & @CRLF & _
"withoutupper1!" & @CRLF & _
"NOLOWERLETTER1!" & @CRLF & _
"NoDigits!" & @CRLF & _
"0SpecSymbols" & @CRLF & _
"ЁasdASD098!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")