re = /^(?=.*[A-Z])(?=.*[!\{\}\[\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\{\}\[\]@#$%^&*()+_<>~-].{7,14}$/m
str = 'TestHey@123!
@TestHey123!
aA1!1111
withoutupper1!
NOLOWERLETTER1!
NoDigits!
0SpecSymbols
ЁasdASD098!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end