const regex = /^(?=.*[A-Z])(?=.*[!\{\}\[\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\{\}\[\]@#$%^&*()+_<>~-].{7,14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[A-Z])(?=.*[!\\{\\}\\[\\]@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z])[^!\\{\\}\\[\\]@#$%^&*()+_<>~-].{7,14}$', 'gm')
const str = `TestHey@123!
@TestHey123!
aA1!1111
withoutupper1!
NOLOWERLETTER1!
NoDigits!
0SpecSymbols
ЁasdASD098!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}