#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[01]?\d|2[0-3])(?::[0-5]\d){1,2}$"
Local $sString = "00:00" & @CRLF & _
"01:00" & @CRLF & _
"09:59" & @CRLF & _
"10:00" & @CRLF & _
"12:00" & @CRLF & _
"13:20" & @CRLF & _
"23:59" & @CRLF & _
"24:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")