$re = '/^(?:[01]?\d|2[0-3])(?::[0-5]\d){1,2}$/m';
$str = '00:00
01:00
09:59
10:00
12:00
13:20
23:59
24:00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);