using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[01]?\d|2[0-3])(?::[0-5]\d){1,2}$";
string input = @"00:00
01:00
09:59
10:00
12:00
13:20
23:59
24:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}