#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-zA-Z])(?=.*[0-9])[a-zA-Z0-9]+$"
Local $sString = "rfvtgbyhnujm" & @CRLF & _
"235675434567" & @CRLF & _
"3edc4rfv5tgb" & @CRLF & _
"cde3vfr4bgt5" & @CRLF & _
"00000000000a" & @CRLF & _
"aaaaaaaaaaa0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")