$re = '/^(?=.*[a-zA-Z])(?=.*[0-9])[a-zA-Z0-9]+$/m';
$str = 'rfvtgbyhnujm
235675434567
3edc4rfv5tgb
cde3vfr4bgt5
00000000000a
aaaaaaaaaaa0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);