using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])(?=.*[0-9])[a-zA-Z0-9]+$";
string input = @"rfvtgbyhnujm
235675434567
3edc4rfv5tgb
cde3vfr4bgt5
00000000000a
aaaaaaaaaaa0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}