using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=['""])[^'""]+(?=[""'],)";
string input = @"case 'cryptocurrencies':
return this.$t('Text dsa dsfdsf asdfd fsdafsdf1', { company: this.$global.company, num: this.$global.companyAge });
case 'currencies':
return this.$t(
'Text sdf3r re432r ff432r 2',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t(""Textf sdf3f dfa sadf 3"", { company: this.$global.company }) } ${ this.$t(""Text 4 dsfasdf a sfasdf"", { num: this.bonus }) }
${ this.$t('Text 3 fsdfasdf', { company: this.$global.company }) } ${ this.$t('Te fsd fasdfdsaxt 4', { num: this.bonus }) }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}