use strict;
my $str = 'case \'cryptocurrencies\':
return this.$t(\'Text dsa dsfdsf asdfd fsdafsdf1\', { company: this.$global.company, num: this.$global.companyAge });
case \'currencies\':
return this.$t(
\'Text sdf3r re432r ff432r 2\',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t("Textf sdf3f dfa sadf 3", { company: this.$global.company }) } ${ this.$t("Text 4 dsfasdf a sfasdf", { num: this.bonus }) }
${ this.$t(\'Text 3 fsdfasdf\', { company: this.$global.company }) } ${ this.$t(\'Te fsd fasdfdsaxt 4\', { num: this.bonus }) }';
my $regex = qr/(?<=['"])[^'"]+(?=["'],)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}