const regex = /(?<=['"])[^'"]+(?=["'],)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\'"])[^\'"]+(?=["\'],)', 'gm')
const str = `case 'cryptocurrencies':
return this.\$t('Text dsa dsfdsf asdfd fsdafsdf1', { company: this.\$global.company, num: this.\$global.companyAge });
case 'currencies':
return this.\$t(
'Text sdf3r re432r ff432r 2',
{
company: this.\$global.company,
num: this.\$global.companyAge
}
);
\${ this.\$t("Textf sdf3f dfa sadf 3", { company: this.\$global.company }) } \${ this.\$t("Text 4 dsfasdf a sfasdf", { num: this.bonus }) }
\${ this.\$t('Text 3 fsdfasdf', { company: this.\$global.company }) } \${ this.\$t('Te fsd fasdfdsaxt 4', { num: this.bonus }) }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}