using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:To|Cc):(?:\h*<?\w[^@]*@\S+>?,?){2,}";
string input = @"To: <yes@aol.com>, <no@aol.com>
Cc: yes@aol.com, no@aol.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}