package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:To|Cc):(?:\h*<?\w[^@]*@\S+>?,?){2,}`)
var str = `To: <yes@aol.com>, <no@aol.com>
Cc: yes@aol.com, no@aol.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}