$re = '~(?:To|Cc):(?:\h*<?\w[^@]*@\S+>?,?){2,}~m';
$str = 'To: <yes@aol.com>, <no@aol.com>
Cc: yes@aol.com, no@aol.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);