const regex = new RegExp('^([a-z]).*\\s([a-z]+)$', 'gm')
const str = `john smith
s r peterson
sandra oh`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);