re = /^([a-z]).*\s([a-z]+)$/m
str = 'john smith
s r peterson
sandra oh'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result