import re
regex = re.compile(r"^([a-z]).*\s([a-z]+)$", flags=re.MULTILINE)
test_str = ("john smith\n"
"s r peterson\n"
"sandra oh")
subst = "\\1 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)