#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(c\/|calle|carrer)?\W?(\w+\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*(?<!num))\W(nº|num|núm|num\.|núm\.|numero|número|n|n\.|no|no\.)?\W?(\d{1,3}\-?\d{1,3}?)\W?(bis|dup|mod|ant)?\W+(BJ)?\W\w+\W"
Local $sString = "calle Monistrol de la vega num 13-15, BJ1 08012 Barcelona " & @CRLF & _
                "calle Monistrol 13, BJ1 08012 Barcelona" & @CRLF & _
                "carrer Monistrol 13, BJ1 08012 Barcelona" & @CRLF & _
                "Monistrol 13, BJ1 08012 Barcelona" & @CRLF & _
                "c/ Monistrol, 13, BJ1 08012 Barcelona" & @CRLF & _
                "calle Monistrol nº 13, BJ1 08012 Barcelona" & @CRLF & _
                "calle Monistrol 13, bajo 1 08012 Barcelona" & @CRLF & _
                "c/ Monistrol 13, Bajo 1º, 08012 Barcelona" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")