using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<q>'|""|´|`)([\w ]+)(\k<q>)";
string input = @"""testt""
'testt'
""testt'
'testt""
`testt`
´testt´
""testt ""
""test test""
something:'firstValue':'secondValue'
something:""firstValue"":'secondValue'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}