$re = '/(?<q>\'|"|´|`)([\w ]+)(\k<q>)/m';
$str = '"testt"
\'testt\'
"testt\'
\'testt"
`testt`
´testt´
"testt "
"test test"
something:\'firstValue\':\'secondValue\'
something:"firstValue":\'secondValue\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);