re = /(?<q>'|"|´|`)([\w ]+)(\k<q>)/m
str = '"testt"
\'testt\'
"testt\'
\'testt"
`testt`
´testt´
"testt "
"test test"
something:\'firstValue\':\'secondValue\'
something:"firstValue":\'secondValue\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end