package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)\">(.|\s)+(<\/xf:if>)`)
var str = `<xf:if is="$post.edit_count && $post.canViewHistory()">
<a href="{{ link('posts/history', $post) }}"
class="actionBar-action actionBar-action--history actionBar-action--menuItem"
data-xf-click="toggle"
data-target="#js-post-{$post.post_id} .js-historyTarget"
data-menu-closer="true">{{ phrase('history') }}</a>
<xf:set var="$hasActionBarMenu" value="{{ true }}" /></xf:if>
<xf:if is="$foo">foo</xf:if>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}