const regex = /<xf:if is="\$post\.edit_count && \$post\.canViewHistory\(\)\">(.|\s)+(<\/xf:if>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<xf:if is="\\$post\\.edit_count && \\$post\\.canViewHistory\\(\\)\\">(.|\\s)+(<\\\/xf:if>)', '')
const str = `<xf:if is="\$post.edit_count && \$post.canViewHistory()">
<a href="{{ link('posts/history', \$post) }}"
class="actionBar-action actionBar-action--history actionBar-action--menuItem"
data-xf-click="toggle"
data-target="#js-post-{\$post.post_id} .js-historyTarget"
data-menu-closer="true">{{ phrase('history') }}</a>
<xf:set var="\$hasActionBarMenu" value="{{ true }}" /></xf:if>
<xf:if is="\$foo">foo</xf:if>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}