#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)a*b*b*a"
Local $sString = "a" & @CRLF & _
"aa" & @CRLF & _
"aba" & @CRLF & _
"abba" & @CRLF & _
"abbbba" & @CRLF & _
"abbbbbba" & @CRLF & _
"abbbbbbbbbbbbba" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")