package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a*b*b*a`)
var str = `a
aa
aba
abba
abbbba
abbbbbba
abbbbbbbbbbbbba
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}