using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a*b*b*a";
string input = @"a
aa
aba
abba
abbbba
abbbbbba
abbbbbbbbbbbbba
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}