#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\d{1,3} (?<PartNum>.*?)\n(?<Description>(?:.|\n)+?)(?=^\d{1,3}|\Z)"
Local $sString = "1 HUY-12" & @CRLF & _
"Description line 1 for the HUY-12" & @CRLF & _
"2 JIU-14" & @CRLF & _
"Description line 1 for the JIU-14" & @CRLF & _
"This one has 2 lines of description" & @CRLF & _
"3 KOI-10" & @CRLF & _
"Description line 1 for the KOI-10" & @CRLF & _
"Second description line" & @CRLF & _
"Third description line" & @CRLF & _
"4 GYT4" & @CRLF & _
"Description line 1 for the GYT4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")