import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,3} (?<PartNum>.*?)\\n(?<Description>(?:.|\\n)+?)(?=^\\d{1,3}|\\Z)";
final String string = "1 HUY-12\n"
+ "Description line 1 for the HUY-12\n"
+ "2 JIU-14\n"
+ "Description line 1 for the JIU-14\n"
+ "This one has 2 lines of description\n"
+ "3 KOI-10\n"
+ "Description line 1 for the KOI-10\n"
+ "Second description line\n"
+ "Third description line\n"
+ "4 GYT4\n"
+ "Description line 1 for the GYT4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}