# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{1,3} (?<PartNum>.*?)\n(?<Description>(?:.|\n)+?)(?=^\d{1,3}|\Z)"
test_str = ("1 HUY-12\n"
"Description line 1 for the HUY-12\n"
"2 JIU-14\n"
"Description line 1 for the JIU-14\n"
"This one has 2 lines of description\n"
"3 KOI-10\n"
"Description line 1 for the KOI-10\n"
"Second description line\n"
"Third description line\n"
"4 GYT4\n"
"Description line 1 for the GYT4")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.