const regex = /^The job has completed,.*?\[\K0[xX][0-9a-fA-F]+(?=\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^The job has completed,.*?\\[\\K0[xX][0-9a-fA-F]+(?=\\])', 'gm')
const str = `Waiting for the completion of job..
.
.
.
.
.
The job has completed, returning [0x0]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}