$re = '/^The job has completed,.*?\[\K0[xX][0-9a-fA-F]+(?=\])/m';
$str = 'Waiting for the completion of job..
.
.
.
.
.
The job has completed, returning [0x0]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);