re = /^The job has completed,.*?\[\K0[xX][0-9a-fA-F]+(?=\])/m
str = 'Waiting for the completion of job..
.
.
.
.
.
The job has completed, returning [0x0]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end