#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:31(\/|-|\.)(?:0?[13578]|1[02]|(?:Jan|Mar|May|Jul|Aug|Oct|Dec)))\1|(?:(?:29|30)(\/|-|\.)(?:0?[1,3-9]|1[0-2]|(?:Jan|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:29(\/|-|\.)(?:0?2|(?:Feb))\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\d|2[0-8])(\/|-|\.)(?:(?:0?[1-9]|(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep))|(?:1[0-2]|(?:Oct|Nov|Dec)))\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$"
Local $sString = "Right Ones" & @CRLF & _
"01/01/2000" & @CRLF & _
"1/1/2000" & @CRLF & _
"01/Jan/2000" & @CRLF & _
"31/01/2000" & @CRLF & _
"31/Jan/2000" & @CRLF & _
"31.Jan.2000" & @CRLF & _
"31-Jan-2000" & @CRLF & _
"28/02/2001" & @CRLF & _
"01/1/2000" & @CRLF & _
"01/Jan/2000" & @CRLF & _
"01/1/01" & @CRLF & _
"01/Jan/01" & @CRLF & _
"29/02/2000" & @CRLF & _
"29/Feb/2000" & @CRLF & _
"" & @CRLF & _
"Wrong Ones" & @CRLF & _
"31/04/2000" & @CRLF & _
"29/Feb/2001" & @CRLF & _
"13/13/2000" & @CRLF & _
"30/Feb/2000" & @CRLF & _
"30/Mon/2000" & @CRLF & _
"32/01/2000" & @CRLF & _
"32/Jan/2000" & @CRLF & _
"01/01/2020 #1st Jan" & @CRLF & _
"07/03/2020 #3 July" & @CRLF & _
"12/2/2020 #2 December " & @CRLF & _
"23/4/2020 #23 April "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")