re = /^(?:(?:31(\/|-|\.)(?:0?[13578]|1[02]|(?:Jan|Mar|May|Jul|Aug|Oct|Dec)))\1|(?:(?:29|30)(\/|-|\.)(?:0?[1,3-9]|1[0-2]|(?:Jan|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:29(\/|-|\.)(?:0?2|(?:Feb))\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\d|2[0-8])(\/|-|\.)(?:(?:0?[1-9]|(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep))|(?:1[0-2]|(?:Oct|Nov|Dec)))\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$/m
str = 'Right Ones
01/01/2000
1/1/2000
01/Jan/2000
31/01/2000
31/Jan/2000
31.Jan.2000
31-Jan-2000
28/02/2001
01/1/2000
01/Jan/2000
01/1/01
01/Jan/01
29/02/2000
29/Feb/2000
Wrong Ones
31/04/2000
29/Feb/2001
13/13/2000
30/Feb/2000
30/Mon/2000
32/01/2000
32/Jan/2000
01/01/2020 #1st Jan
07/03/2020 #3 July
12/2/2020 #2 December
23/4/2020 #23 April '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end