#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)."
Local $sString = "Right Ones" & @CRLF & _
"01/01/2000" & @CRLF & _
"1/1/2000" & @CRLF & _
"01/Jan/2000" & @CRLF & _
"31/01/2000" & @CRLF & _
"31/Jan/2000" & @CRLF & _
"31.Jan.2000" & @CRLF & _
"31-Jan-12" & @CRLF & _
"31-Jan-1983" & @CRLF & _
"28/02/2001" & @CRLF & _
"01/1/2000" & @CRLF & _
"01/Jan/2000" & @CRLF & _
"01/1/01" & @CRLF & _
"01/Jan/01" & @CRLF & _
"29/02/2000" & @CRLF & _
"29/Feb/2000" & @CRLF & _
"01/01/2020 #1st Jan" & @CRLF & _
"07/03/2020 #3 July" & @CRLF & _
"12/2/2020 #2 December " & @CRLF & _
"23/4/2020 #23 April " & @CRLF & _
"" & @CRLF & _
"Wrong Ones" & @CRLF & _
"31/04/2000" & @CRLF & _
"29/Feb/2001" & @CRLF & _
"13/13/2000" & @CRLF & _
"30/Feb/2000" & @CRLF & _
"25/February/2000" & @CRLF & _
"32/01/2000" & @CRLF & _
"32/Jan/2000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")