// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).").unwrap();
let string = "Right Ones
01/01/2000
1/1/2000
01/Jan/2000
31/01/2000
31/Jan/2000
31.Jan.2000
31-Jan-12
31-Jan-1983
28/02/2001
01/1/2000
01/Jan/2000
01/1/01
01/Jan/01
29/02/2000
29/Feb/2000
01/01/2020 #1st Jan
07/03/2020 #3 July
12/2/2020 #2 December
23/4/2020 #23 April
Wrong Ones
31/04/2000
29/Feb/2001
13/13/2000
30/Feb/2000
25/February/2000
32/01/2000
32/Jan/2000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}