use strict;
my $str = 'Right Ones
01/01/2000
1/1/2000
01/Jan/2000
31/01/2000
31/Jan/2000
31.Jan.2000
31-Jan-12
31-Jan-1983
28/02/2001
01/1/2000
01/Jan/2000
01/1/01
01/Jan/01
29/02/2000
29/Feb/2000
01/01/2020 #1st Jan
07/03/2020 #3 July
12/2/2020 #2 December
23/4/2020 #23 April
Wrong Ones
31/04/2000
29/Feb/2001
13/13/2000
30/Feb/2000
25/February/2000
32/01/2000
32/Jan/2000
';
my $regex = qr/./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}