import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(generate|create|draw|make) (me|an?|the|this|that)? .* (of|for|about|showing|depicting|illustrating)";
final String string = "Generate an epic image of a dragon in flight\n"
+ "Create a realistic render of a futuristic city\n"
+ "Generate the perfect logo for a tech startup\n"
+ "Create this concept art for a fantasy novel\n"
+ "Generate that illustration about ancient myths\n"
+ "Create an animation showing a volcano eruption\n"
+ "Generate a portrait depicting a medieval knight\n"
+ "Draw me a dragon of fire\n\n"
+ "Type your prompt below!\n"
+ "As long as the first parts of it are highlighted in multiple colors, like the examples above, the script will reconigize your prompt and generate and image.\n\n"
+ "Type here...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}