# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(generate|create|draw|make) (me|an?|the|this|that)? .* (of|for|about|showing|depicting|illustrating)"
test_str = ("Generate an epic image of a dragon in flight\n"
"Create a realistic render of a futuristic city\n"
"Generate the perfect logo for a tech startup\n"
"Create this concept art for a fantasy novel\n"
"Generate that illustration about ancient myths\n"
"Create an animation showing a volcano eruption\n"
"Generate a portrait depicting a medieval knight\n"
"Draw me a dragon of fire\n\n"
"Type your prompt below!\n"
"As long as the first parts of it are highlighted in multiple colors, like the examples above, the script will reconigize your prompt and generate and image.\n\n"
"Type here...")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.