$re = '/^(generate|create|draw|make) (me|an?|the|this|that)? .* (of|for|about|showing|depicting|illustrating)/mi';
$str = 'Generate an epic image of a dragon in flight
Create a realistic render of a futuristic city
Generate the perfect logo for a tech startup
Create this concept art for a fantasy novel
Generate that illustration about ancient myths
Create an animation showing a volcano eruption
Generate a portrait depicting a medieval knight
Draw me a dragon of fire
Type your prompt below!
As long as the first parts of it are highlighted in multiple colors, like the examples above, the script will reconigize your prompt and generate and image.
Type here...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);