#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)USERS: ([^!]*[a-zA-Z]\d{3})![^@]+@[^ ]+ \([^) ]+\) \(\S+\) connected to the network "
Local $sString = "USERS: Stephanie800!Mibbit@xx.xx.xx.xx (555560E4.5124B86E.EB45475D.IP) (http://www.mibbit.com) connected to the network (our network is here)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")